Y a pas à dire… Il y a des semaines à bugs…

Il y a des semaines qui commencent en fanfare sur le plan informatique. Celle qui a commencé le 12 juillet est une semaine qui va être bien chargée côté bugs rapportés sur les différents projets que j’utilise au quotidien.

Aveu préliminaire : j’utilise pas mal de logiciels en version de développement, il est donc normal que je sois face à des bugs. Pour être plus clair, oui, je cherche la merde.

Tout a commencé dimanche 11 juillet dans l’après-midi. En voulant mettre en place une machine virtuelle avec EndeavourOS à l’intérieur, je m’aperçois de la présence de plantages avec LightDM. En fouillant sur l’outil de suivi de bugs d’Archlinux, je tombe sur une entrée qui colle à mon problème.

Je finis par trouver le bug correspondant sur l’outil de suivi de Xorg, et après avoir recherché le code responsable, je trouve l’ajout qui semble être responsable du merdier.

Premier bug de la semaine en voie d’avancement pour la correction. Le deuxième est plus marrant, car on pourrait parler de bug en cascade. Je m’explique.

Je suis utilisateur et mainteneur sur AUR de qemu-git, la version de développement de Qemu qui est un peu la version 100% libre de VirtualBox. Oui, je sais que les puristes vont sortir les torches et préparer le bûcher pour m’y faire cuire comme une merguez, mais c’est pour l’image.

Aux alentours du 7 juillet, j’avais rapporté un bug de compilation qui faisait que le processus s’arrêtait très tôt. Un correctif a été créé et ajouté dans un lot d’autres correctifs. Pour le moment, tout allait bien. Mais non.

Je tente donc lundi après-midi de faire compiler une nouvelle version de développement pour voir si le code ajouté est correct. C’est le cas, mais j’ai droit à un nouveau plantage plutôt tardif du processus de compilation.

J’ai donc ouvert un autre bug dans la foulée… On parie que le correctif pour ce problème fera exploser en vol une nouvelle fois la compilation ?

J’ai aussi parlé rapidement d’un bug que j’ai découvert dans la version de développement de Dosbox-X, mais je vous renvoie à l’article correspondant.

Déjà 4 bugs, et on est que mardi matin… Mais quand on aime, on ne compte pas.

Ce matin, je voulais faire compiler le code de développement de l’émulateur Vice (Commodore PET, Vic20, C64/128, Plus4) et j’ai eu droit à un autre bug de compilation.

Un cinquième bug, le quatrième que j’ai ouvert en l’espace de moins de 36 heures, rédigeant ce billet vers 10 h 00 du matin.

Sur le forum d’EndeavourOS, j’ai pris comme « surnom » sur ma fiche un humoristique « Bugman approved! ». À croire qu’en ce moment, ça me colle bien à la peau !

11 réflexions sur « Y a pas à dire… Il y a des semaines à bugs… »

  1. en parlant de virtualbox, il commence à me gonfler sévère.

    niveau graphique il faut vraiment que l’équipe se bouge le derrière.
    virtualbox reste toujours sur du opengl 2.1 et je suis même pas sûr qu’il est compatible directx 10.

    windows 10 rame, et de simple petit jeux sur de grande maps rame à cause de virtualbox.

  2. j’aimerais bien installer vmware player pour remplacer virtualbox mais quand je veux l’installer il me dit un drôle de message d’extraterrestre.
    https://zupimages.net/up/21/28/jw9c.png

    est ce que quelqu’un a une idée ?
    faut-il démarrer un service ?
    faut-il créer quelque chose avant ?
    faut-il boire un café avant installation ?

Les commentaires sont fermés.

Vous pouvez surfer l’esprit libre, il n’y a ni trackeurs ni cookies sur ce site. Plus d’informations

Les paramètres des cookies sur ce site sont définis sur « accepter les cookies » pour vous offrir la meilleure expérience de navigation possible. Si vous continuez à utiliser ce site sans changer vos paramètres de cookies ou si vous cliquez sur "Accepter" ci-dessous, vous consentez à cela.

Fermer