Abiword 3.0 : un coup de fouet bienvenu pour Gnome Office ?

Gnome Office, c’est un ensemble de logiciels constituant une trousse bureautique pour Gnome (et tout environnement utilisant gtk comme Xfce). Elle est composée dixit le wiki de Gnome par :

  • AbiWord : traitement de texte
  • Evince : afficheur de documents, partie intégrante de Gnome)
  • Evolution : l’outil de courrier électronique officiel et de travail collaboratif de Gnome
  • Gnumeric : le tableur
  • Inkscape : dessin vectoriel
  • Ease : Présentations (en développement interrompu ?)

Parmi les logiciels tous sont (à l’exception d’Ease) bien avancés. Le seul qui était encore en retrait, c’était Abiword. Hubert Figuière a annoncé sur la liste de publication « abiword-dev » la sortie du code source d’Abiword 3.0.

J’ai donc récupéré le PKGBUILD de la version 2.8.6, et je l’ai modifié pour obtenir une version compilée de cette nouvelle mouture. Et si vous utilisez ce PKGBUILD, c’est à vos risques et périls. Je suis suffisamment clair ? 😉

Voici l’adaptation non officielle et fonctionnelle pour avoir Abiword 3.0 sur une Archlinux. J’ai du désactiver les greffons qui m’envoyait paître à chaque fois avec une erreur de compilation. Dommage !


# $Id: PKGBUILD 184359 2013-05-06 19:36:30Z foutrelis $
# Maintainer: Giovanni Scafora
# Contributor: Maël Lavault


pkgbase=abiword
pkgname=('abiword')
pkgver=3.0.0
pkgrel=1
arch=('i686' 'x86_64')
license=('GPL')
url="http://www.abisource.com"
makedepends=('pkgconfig' 'asio' 'boost' 'fribidi' 'goffice' 'libwmf' 'wv' 'link-grammar' 'gtkmathview' 'aiksaurus' 'libxslt' 'enchant' 'libots' 'libwpg' 'librsvg' 'loudmouth' 'libsoup' 'psiconv')
options=('!makeflags' '!libtool')
source=(http://www.abisource.com/downloads/${pkgbase}/${pkgver}/source/${pkgbase}-${pkgver}.tar.gz)
md5sums=('8d9c41cff3a8fbef8d0c835c65600e65')


build() {
cd "${srcdir}/${pkgbase}-${pkgver}"


./configure --prefix=/usr \
--enable-clipart \
--enable-templates \
--enable-collab-backend-xmpp \
--enable-collab-backend-tcp \
--enable-collab-backend-service \
--disable-collab-backend-sugar \
--enable-plugins --without-gnomevfs \
--with-gio \
--with-goffice \
--disable-static \
--without-evolution-data-server \
--with-psiconv-config=/nothere
make
}


package_abiword() {
pkgdesc="A fully-featured word processor"
depends=('fribidi' 'wv' 'goffice' 'librsvg' 'enchant' 'desktop-file-utils')
install=$pkgname.install
optdepends=('abiword-plugins')
conflicts=("abiword-plugins< ${pkgver}-${pkgrel}")


cd "${srcdir}/${pkgbase}-${pkgver}"
sed -i plugins/Makefile \
-e 's/ collab / /' \
-e 's/ wpg / /' \
-e 's/ wmf / /' \
-e 's/ grammar / /' \
-e 's/ mathview / /' \
-e 's/ aiksaurus / /' \
-e 's/ latex / /' \
-e 's/ ots / /' \
-e 's/ wordperfect / /'
make DESTDIR="${pkgdir}" install
}

Le mieux est de montrer Abiword en action. C’est tiré du paquet que j’ai compilé. La version officielle qui sera disponible sur les dépots d’Archlinux ou de votre distribution GNU/Linux préférée sera sûrement plus policée. La bande son est extraite de « Merysland » de KesakoO.

Abiword est un outil à l’évolution lente, mais continue. Il est loin d’atteindre le niveau de complexité d’un monstre comme LibreOffice ou encore Apache OpenOffice. Mais pour des petits travaux bureautique, c’est largement suffisant. Dommage que je n’ai pas réussi à activer le correcteur orthographique et grammatical cependant 🙁

5 réflexions sur « Abiword 3.0 : un coup de fouet bienvenu pour Gnome Office ? »

  1. L’un des problèmes d’Abiword est sa licence sous GPL v2 qui empêche les développeurs d’utiliser du code des logiciels Writer d’AOO et de LibreOffice car leurs licences sont (APSL 2.0 et LGPL v3) sont incompatibles avec la GPL v2. Gnumeric n’a pas ce problème puisqu’elle utilise une double licence GPL v2 ET v3 qui est compatible avec la licence Apache et la LGPL v3.

Les commentaires sont fermés.

Vous pouvez surfer l’esprit libre, il n’y a ni trackeurs ni cookies sur ce site. Plus d’informations

Les paramètres des cookies sur ce site sont définis sur « accepter les cookies » pour vous offrir la meilleure expérience de navigation possible. Si vous continuez à utiliser ce site sans changer vos paramètres de cookies ou si vous cliquez sur "Accepter" ci-dessous, vous consentez à cela.

Fermer