Du besoin d’une implémentation puissante et libre d’Adobe Flash – partie 2 – swfdec

Swfdec est une des deux alternatives libre au greffon propriétaire Adobe Flash. Voulant tester une version récente, j’ai installé la version de développement 0.9.2 disponible sur AUR avec son extension pour être utilisable avec Mozilla Firefox.

Après avoir créé un lien symbolique du fichier /usr/lib/mozilla/plugins/libswfdecmozilla.so vers ~/.mozilla/plugins et relancé le navigateur, j’ai voulu tester les 3 sites que j’utilise principalement avec Adobe Flash : Youtube, Deezer et Dailymotion.

Les résultats ? Ecran noir sur Youtube, Deezer m’annonce que ma version d’Adobe Flash est trop vieille, et Dailymotion me plante le navigateur 🙁

Swfdec 0.9.2 avec Youtube

Swfdec 0.9.2 avec Deezer

J’ai donc voulu voir si c’était mieux du coté des versions de développement… Et le paquet ne se compile pas, que ce soit la version utilisant pulse-audio ou celle utilisant alsa :

libtool: compile: gcc -DHAVE_CONFIG_H -I. -I.. -Wall -Wextra -Wno-missing-field-initializers -Wno-unused-parameter -Wold-style-definition -Wdeclaration-after-statement -Wmissing-declarations -Wmissing-prototypes -Wredundant-decls -Wmissing-noreturn -Wshadow -Wpointer-arith -Wcast-align -Wwrite-strings -Winline -Wformat-nonliteral -Wformat-security -Wswitch-enum -Wswitch-default -Winit-self -Wmissing-include-dirs -Wundef -Waggregate-return -Wmissing-format-attribute -Wnested-externs -Wunsafe-loop-optimizations -Wpacked -Winvalid-pch -Wsync-nand -Wlogical-op -Werror -std=gnu99 -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -pthread -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pango-1.0 -I/usr/include/cairo -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng12 -I.. -I./jpeg/ -I/usr/include/liboil-0.3 -pthread -I/usr/include/gstreamer-0.10 -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/libxml2 -DG_LOG_DOMAIN=\ »Swfdec\ » -march=x86-64 -mtune=generic -O2 -pipe -MT libswfdec_0.9_la-swfdec_as_string.lo -MD -MP -MF .deps/libswfdec_0.9_la-swfdec_as_string.Tpo -c swfdec_as_string.c -fPIC -DPIC -o .libs/libswfdec_0.9_la-swfdec_as_string.o
cc1: warnings being treated as errors
swfdec_as_string.c: In function ‘swfdec_as_string_split_5’:
swfdec_as_string.c:369: erreur: logical ‘&&’ with non-zero constant will always evaluate as true
make[4]: *** [libswfdec_0.9_la-swfdec_as_string.lo] Erreur 1
make[4]: quittant le répertoire « /tmp/yaourt-tmp-fred/aur-swfdec-git/swfdec-git/src/swfdec-build/swfdec »
make[3]: *** [all-recursive] Erreur 1
make[3]: quittant le répertoire « /tmp/yaourt-tmp-fred/aur-swfdec-git/swfdec-git/src/swfdec-build/swfdec »
make[2]: *** [all] Erreur 2
make[2]: quittant le répertoire « /tmp/yaourt-tmp-fred/aur-swfdec-git/swfdec-git/src/swfdec-build/swfdec »
make[1]: *** [all-recursive] Erreur 1
make[1]: quittant le répertoire « /tmp/yaourt-tmp-fred/aur-swfdec-git/swfdec-git/src/swfdec-build »
make: *** [all] Erreur 2

Bref, ce n’est pas la joie. J’espère que Gnash – objet du prochain article – s’en tirera un peu mieux !

Du besoin d’une implémentation puissante et libre d’Adobe Flash – partie 1

Il y a quelques jours, Adobe annonçait l’arrivée de la première préversion d’Adobe Flash 10.1. Alors que la version 64 bits du greffon flash pour Linux en 64 bits n’a pas été mise à jour depuis juillet dernier, Adobe annonce que cette préversion est uniquement en 32 bits dixit Phoronix :

Alongside the Windows and Mac OS X beta releases was a 32-bit Linux build, but the 64-bit build isn’t yet available so those users will need to be use the earlier 64-bit beta.

Ce qui donne traduit :

A côté des versions bêta pour Windows et MacOS X il y aune version 32 bits pour linux, mais la version 64 bits n’est pas encore disponible donc les utilisateurs – de 64 bits – devront encore utiliser la version 64 bits précédente.

Ou utiliser nspluginwrapper, ce qui n’est pas franchement la joie. Il ne reste plus que deux options : gnash ou swfdec. Objet de deux articles qui viendront d’ici peu.

Swfdec 0.5.5 : enfin un flash libre potable ?

Au moins, pour visionner les sites de vidéos en ligne comme Dailymotion ou encore youtube. Contrairement à l’usine à gaz qu’est devenu Gnash, Swfdec fonctionne avec Dailymotion. Enfin, ne plus avoir besoin de NsPluginWrapper sur les linux 64 bits 😉

Pour installer le greffon dans Firefox ou Epiphany sous Archlinux :

sudo pacman -S swfdec-mozilla

Ensuite, il suffit de lancer Firefox ou Epiphany, et de voir le résultat :

Swfdec en action avec Epiphany sous ArchLinux 64 bits.

Le seul gros problème est qu’il faut lancer manuellement les vidéos via un clic droit puis « play ».

Si NsPluginWrapper – donc distribution en 64 bits – avait été installé auparavant, il suffit d’enlever les dépendances, en utilisant yaourt :


$ yaourt -R nspluginwrapper-flash
$ yaourt -R lib32

La deuxième ligne virant les paquets lib32 (32 bits) s’ils ne sont pas utilisé par d’autres logiciels ayant des dépendances comme Wine par exemple.

Vous pouvez surfer l’esprit libre, il n’y a ni trackeurs ni cookies sur ce site. Plus d’informations

Les paramètres des cookies sur ce site sont définis sur « accepter les cookies » pour vous offrir la meilleure expérience de navigation possible. Si vous continuez à utiliser ce site sans changer vos paramètres de cookies ou si vous cliquez sur "Accepter" ci-dessous, vous consentez à cela.

Fermer